Permutations of String Array in Recursion

Recently I have attended one Hackathon event organized by the Amazon in the Delhi. In this event I have face two technical problems as below.
  1. Permutations of String 
  2. Product Maximization Problem

There is one of two problems I have face in the Hackathon Delhi in the amazon hiring process.

Problem:

Given a set of characters and a positive integer k, print all possible strings of length k that can be formed from the given set in sorted order.

Input format:

First line contains the number of characters.

Second line contains the characters separated by space. Assume the characters are in sorted order and all in lower case.

Third line contains k.

SAMPLE INPUT
2
a b
3
SAMPLE OUTPUT
aaa
aab
aba
abb
baa
bab
bba
bbb

Solution:

package com.dineshonjava.algo;

import java.util.Scanner;

public class StringPermutation {

 private static Scanner sc;

 public static void main(String[] args) {
  sc = new Scanner(System.in);
  int N = sc.nextInt();
  String [] charArray = new String [N];
  for(int i = 0; i < N ; i++){
   charArray [i] = sc.next();
  }
  int k = sc.nextInt();
  calculatePermutations(k, charArray, "");
 }
 
 private static void calculatePermutations(final int k, final String[] charArray, final String currentWord) {
     if (k == 0) {
         System.out.println(currentWord);
     } else {
         for (int i = 0; i < charArray.length; i++) {
          calculatePermutations(k - 1, charArray, currentWord + charArray[i]);
         }
     }
 }
}

Now run this application:

Go to command prompt or go to any IDE like eclipse or STS and first compile this java file and then run it.

>Java StringPermutation
2
a b
3

Output as below:
aaa
aab
aba
abb
baa
bab
bba
bbb

Another second question was one of the two questions is Product Maximization.

Previous
Next
Dinesh Rajput

Dinesh Rajput is the chief editor of a website Dineshonjava, a technical blog dedicated to the Spring and Java technologies. It has a series of articles related to Java technologies. Dinesh has been a Spring enthusiast since 2008 and is a Pivotal Certified Spring Professional, an author of a book Spring 5 Design Pattern, and a blogger. He has more than 10 years of experience with different aspects of Spring and Java design and development. His core expertise lies in the latest version of Spring Framework, Spring Boot, Spring Security, creating REST APIs, Microservice Architecture, Reactive Pattern, Spring AOP, Design Patterns, Struts, Hibernate, Web Services, Spring Batch, Cassandra, MongoDB, and Web Application Design and Architecture. He is currently working as a technology manager at a leading product and web development company. He worked as a developer and tech lead at the Bennett, Coleman & Co. Ltd and was the first developer in his previous company, Paytm. Dinesh is passionate about the latest Java technologies and loves to write technical blogs related to it. He is a very active member of the Java and Spring community on different forums. When it comes to the Spring Framework and Java, Dinesh tops the list!

Share
Published by
Dinesh Rajput

Recent Posts

Strategy Design Patterns using Lambda

Strategy Design Patterns We can easily create a strategy design pattern using lambda. To implement…

2 years ago

Decorator Pattern using Lambda

Decorator Pattern A decorator pattern allows a user to add new functionality to an existing…

2 years ago

Delegating pattern using lambda

Delegating pattern In software engineering, the delegation pattern is an object-oriented design pattern that allows…

2 years ago

Spring Vs Django- Know The Difference Between The Two

Technology has emerged a lot in the last decade, and now we have artificial intelligence;…

2 years ago

TOP 20 MongoDB INTERVIEW QUESTIONS 2022

Managing a database is becoming increasingly complex now due to the vast amount of data…

2 years ago

Scheduler @Scheduled Annotation Spring Boot

Overview In this article, we will explore Spring Scheduler how we could use it by…

2 years ago