Permutations of String Array in Recursion

Recently I have attended one Hackathon event organized by the Amazon in the Delhi. In this event I have face two technical problems as below.

  1. Permutations of String 
  2. Product Maximization Problem

There is one of two problems I have face in the Hackathon Delhi in the amazon hiring process.

Problem:

Given a set of characters and a positive integer k, print all possible strings of length k that can be formed from the given set in sorted order.

Input format:

First line contains the number of characters.

Second line contains the characters separated by space. Assume the characters are in sorted order and all in lower case.

Third line contains k.

SAMPLE INPUT
2
a b
3
SAMPLE OUTPUT
aaa
aab
aba
abb
baa
bab
bba
bbb

Solution:

package com.dineshonjava.algo;

import java.util.Scanner;

public class StringPermutation {

 private static Scanner sc;

 public static void main(String[] args) {
  sc = new Scanner(System.in);
  int N = sc.nextInt();
  String [] charArray = new String [N];
  for(int i = 0; i < N ; i++){
   charArray [i] = sc.next();
  }
  int k = sc.nextInt();
  calculatePermutations(k, charArray, "");
 }
 
 private static void calculatePermutations(final int k, final String[] charArray, final String currentWord) {
     if (k == 0) {
         System.out.println(currentWord);
     } else {
         for (int i = 0; i < charArray.length; i++) {
          calculatePermutations(k - 1, charArray, currentWord + charArray[i]);
         }
     }
 }
}

Now run this application:

Go to command prompt or go to any IDE like eclipse or STS and first compile this java file and then run it.

>Java StringPermutation
2
a b
3

Output as below:
aaa
aab
aba
abb
baa
bab
bba
bbb

Another second question was one of the two questions is Product Maximization.

Previous
Next